I am having trouble when naming a variable, deciding if I should use ABC種別 or ABC区分. I have been reading a lot of software specifications and the Japanese description usually uses 種別 and 区分 to specify a type or a class.
When do you use 種別 and when do you use 区分? For example, for a device, would you use 種別 or 区分 to differentiate the type here? Is this just a preference?
Added based on the context comments (2011/12/12): I was referring to customer types. I do ask my colleague, why they use 区分、種別 or even 種類 pertaining to the same variable but they just say they are the same. Example of usage that I see, for example column names of database tables (Customer=>TOKUI_KUBUN,TOKUI_SHUBETSU) or (User=>USER_KUBUN,USER_SHUBETSU). I do think they are essentially the same with subtle difference. It just is annoying which one is the more appropriate one especially if you want to make a naming convention.